Error messages with Invoke-ASDiscover AND Send-XmlaDiscover

Nov 16, 2011 at 9:10 AM

Some of the Cmdlets work really fine like Get-ASServer, Get-ASDatabase and Get-ASCube but some fail with these errors.

PS C:\> invoke-asdiscover Server\Instance DISCOVER_CONNECTIONS | ft

Invoke-AsDiscover : The SelectCommand property has not been initialized before calling 'Fill'.

At line:1 char:18

+ invoke-asdiscover <<<<  Server\Instance DISCOVER_CONNECTIONS | ft

    + CategoryInfo          : NotSpecified: (:) [Invoke-AsDiscover], InvalidOperationException

    + FullyQualifiedErrorId : System.InvalidOperationException,Gosbell.PowerSSAS.Cmdlets.CmdletSendXmlaDiscover

 

PS C:\> send-XmlaDiscover Server\Instance DISCOVER_SCHEMA_ROWSETS

The term 'send-XmlaDiscover' is not recognized as the name of a cmdlet, function, script file, or operable program.

Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

At line:1 char:18

+ send-XmlaDiscover <<<<  Server\Instance DISCOVER_SCHEMA_ROWSETS

    + CategoryInfo          : ObjectNotFound: (send-XmlaDiscover:String) [], CommandNotFoundException

    + FullyQualifiedErrorId : CommandNotFoundException

 

Coordinator
Nov 16, 2011 at 7:02 PM

Thanks for reporting this, I think I have all these issues fixed I just working on a new installer which will give the option of installing as a either a PowerShell v1 snap-in (which needs to write to the registry) or as a v2 module (which is a simple file copy)