Errors with get-ASConnection and get-ASCube

Nov 8, 2011 at 11:27 AM

I'm having trouble with both of the above. The error messages are

------------------------------------------------------------------------------

PS C:\AMOScripts> Get-ASServer Server\Instance | Get-ASConnection

Get-ASConnection : Systemfehler: Invalid procedure call or argument.

At line:1 char:49

+ Get-ASServer Server\Instance | Get-ASConnection <<<<

   + CategoryInfo         : NotSpecified: (:) [Get-ASConnection], AdomdErrorResponseException

   + FullyQualifiedErrorId : Microsoft.AnalysisServices.AdomdClient.AdomdErrorResponseException,Gosbell.PowerSSAS.Cmdlets.CmdletGetASConnection

 

PS C:\AMOScripts> Get-ASSession Server\Instance

Get-ASSession : The SelectCommand property has not been initialized before calling 'Fill'.

At line:1 char:14

+ Get-ASSession <<<< Server\Instance

   + CategoryInfo         : NotSpecified: (:) [Get-ASSession], InvalidOperationException

   + FullyQualifiedErrorId : System.InvalidOperationException,Gosbell.PowerSSAS.Cmdlets.CmdletGetASSession

Coordinator
Nov 8, 2011 at 11:28 PM

does get-ASConnection work if you just pass in the server\instance name rather than passing a server object?

eg.   get-ASConnection localhost\sql08

I've done a bit of refactoring on the code base since the last release and I'm not able to replicate the exact errors although there does still seem to be an issue with piping a server object to get-ASConnection which I'll have to look into.

Nov 9, 2011 at 7:50 AM

Hi Darren,

I'm afraid this is the error message I'm getting. Thanks for your help.

PS C:\> Get-ASConnection Server\Instance
Get-ASConnection : The SelectCommand property has not been initialized before calling 'Fill'.
At line:1 char:17
+ Get-ASConnection <<<<  Server\Instance
    + CategoryInfo          : NotSpecified: (:) [Get-ASConnection], InvalidOperationException
    + FullyQualifiedErrorId : System.InvalidOperationException,Gosbell.PowerSSAS.Cmdlets.CmdletGetASConnection